depo güncelleme sorunu

Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
20-07-2022 08:50 #1

[email protected]: ~ $ sudo pisi up
Depolar güncelleniyor
Depo güncelleniyor: Stable
pisi-index.xml.xz.sha1sum      (40.0  B)100%    721.76 KB/s [00:00:00] [tamamlandı]
Stable depo bilgisi güncel.
Depo güncelleniyor: contrib
pisi-index.xml.xz.sha1sum      (40.0  B)100%    583.06 KB/s [00:00:00] [tamamlandı]
contrib depo bilgisi güncel.
Emniyet mandalı aşağıdaki paketlerin yükseltilmesini zorunlu kılıyor:
audit            baselayout    bash           biosdevname  busybox          
ca-certificates  comar         curl           dbus         dbus-glib    
dbus-python      efivar        expat          gettext      glib2        
glibc            kmod          leveldb        libX11       libgcc       
libkmod          libnghttp2    libquadmath    libssh2      libtirpc     
libunwind        libusb        libusb-compat  libxcb       libxml2      
lz4              man-pages     mit-kerberos   ncurses      nspr         
openssl          pam           pciutils       pisi         plyvel       
polkit           pycurl        pypolkit       python       python-audit
shadow           spidermonkey  sqlite         texinfo      unzip        
usbutils         zlib          zstd          
libdrm sürüm 19 bağımlılığı, libkms paketi için sağlanamadı.
Sistem hatası. Program sonlandırıldı.
Yükseltme mümkün değil.
Genel yardım için lütfen 'pisi help' komutunu kullanınız.
Geri izleme verisi almak için lütfen --debug seçeneğini kullanın.
[email protected]: ~ $ --debug
bash: --debug: komut yok
[email protected]: ~ $ sudo pisi up
Depolar güncelleniyor
Depo güncelleniyor: Stable
pisi-index.xml.xz.sha1sum      (40.0  B)100%    910.22 KB/s [00:00:00] [tamamlandı]
Stable depo bilgisi güncel.
Depo güncelleniyor: contrib
pisi-index.xml.xz.sha1sum      (40.0  B)100%    574.88 KB/s [00:00:00] [tamamlandı]
contrib depo bilgisi güncel.
Emniyet mandalı aşağıdaki paketlerin yükseltilmesini zorunlu kılıyor:
audit         baselayout  bash          biosdevname  busybox  ca-certificates  comar     curl     dbus  dbus-glib  dbus-python   efivar   expat  gettext  glib2  glibc     kmod  leveldb  libX11  libgcc  libkmod   libnghttp2
libquadmath   libssh2     libtirpc      libunwind    libusb   libusb-compat    libxcb    libxml2  lz4   man-pages  mit-kerberos  ncurses  nspr   openssl  pam    pciutils  pisi  plyvel   polkit  pycurl  pypolkit  python     
python-audit  shadow      spidermonkey  sqlite       texinfo  unzip            usbutils  zlib     zstd
libdrm sürüm 19 bağımlılığı, libkms paketi için sağlanamadı.
Sistem hatası. Program sonlandırıldı.                                                                                                                                                                                                        
Yükseltme mümkün değil.                                                                                                                                                                                                                      
Genel yardım için lütfen 'pisi help' komutunu kullanınız.                                                                                                                                                                                    
Geri izleme verisi almak için lütfen --debug seçeneğini kullanın.
[email protected]: ~ $

Çözümü nedir acaba.


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
12-08-2022 11:16 #2

çözümsüz bir soru sordum galiba. 4. değişik bilgisayara enaz 20 kez kurulum yaptım. isoyu tekrar tekrar indirip yine temiz kurulum yatım ama nafile. ubuntuyla devam edeceğiz galiba.

 


ERKAN IŞIK
Katılım
: 31-08-2017
Mesajlar
: 426
12-08-2022 11:22 #3

sudo pisi up -dvys olarak deneyin


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
12-08-2022 11:41 #4

libdrm sürüm 19 bağımlılığı, libkms paketi için sağlanamadı.
Sistem hatası. Program sonlandırıldı.                                                                               
<type 'exceptions.Exception'>: Yükseltme mümkün değil.                                                              
Genel yardım için lütfen 'pisi help' komutunu kullanınız.                                                           

Geri iz:
 File "/usr/bin/pisi", line 84, in <module>
   cli.run_command()
 File "/usr/lib/pisilinux/pisi/cli/pisicli.py", line 144, in run_command
   self.command.run()
 File "/usr/lib/pisilinux/pisi/cli/upgrade.py", line 106, in run
   pisi.api.upgrade(packages, repository)
 File "/usr/lib/pisilinux/pisi/api.py", line 70, in wrapper
   ret = func(*__args,**__kw)
 File "/usr/lib/pisilinux/pisi/api.py", line 442, in upgrade
   return pisi.operations.upgrade.upgrade(packages, repo)
 File "/usr/lib/pisilinux/pisi/operations/upgrade.py", line 165, in upgrade
   G_f, order = plan_upgrade(A, replaces=replaces)
 File "/usr/lib/pisilinux/pisi/operations/upgrade.py", line 337, in plan_upgrade
   add_runtime_deps(pkg, Bp)
 File "/usr/lib/pisilinux/pisi/operations/upgrade.py", line 268, in add_runtime_deps
   raise Exception(_("Upgrade is not possible."))
[email protected]: ~ $


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
12-08-2022 11:42 #5

ekranda çıkan görüntü böyle


Kamil Atlı
Katılım
: 29-03-2018
Mesajlar
: 63
12-08-2022 12:27 #6

Önce libkms paketini sistem silin.. sonra,

sudo pisi ur sudo pisi up -sy

Düzelecektir. Bilgi için teşekkürler.


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
12-08-2022 15:02 #7

Kuruluyor 48 / 412                                                                                                  
efivar-38-11-p2-x86_64.pisi [önbellekte]
efivar paketi 38 sürümü 11 yayımı kuruluyor
Yeni ana kaynak sürüme yükseltiliyor.                                                                               
efivar için kaldırma öncesi işlemler çalıştırılıyor
Sistem hatası. Program sonlandırıldı.
org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1                       
Genel yardım için lütfen 'pisi help' komutunu kullanınız.                                                           
Geri izleme verisi almak için lütfen --debug seçeneğini kullanın.

kamil bey şimdide böyle bir hata verdi

 


Kamil Atlı
Katılım
: 29-03-2018
Mesajlar
: 63
12-08-2022 16:36 #8

sudo pisi rm libkms --ignore-dependency

İle o paket sistemden sorunsuzca kaldirabilirsiniz.

Depoda anlık bir hata olsa gerek, önce güncellemeleri tıklayın veya,

sudo pisi ur

sonra yeniden deneyin.


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
15-08-2022 12:14 #9

Kamil bey ilginiz için teşekkür ederim. bilgisayarım arızalandı. tekrar kurulum yapıp sonucu buaradan paylaşacağım. bu mesajı kurumun bilgisayarından yazıyorum.


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
15-08-2022 14:48 #10

pisilinux2 login: _

Burada kalıyoruz. İleri gitmiyor.


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
15-08-2022 19:13 #11

Erkan beyin açılış sorunu ile ilgili anlatımını uyguladıktan sonra sonucu yazarım yine. 

 


Baki TATAR
Katılım
: 04-06-2018
Mesajlar
: 14
16-08-2022 14:31 #12

tekrar merhaba. Pisi GNU/Linux 2.2 KDE Crocus Ancyrensis sürümü ile kurulumu bir türlü başaramadım (benim bilgisayar baya eski belki ondan bilemiyorum). herseferinde değişik hata mesajları aldım(yaklaşık 20 kez 4 değişik bilgisayarla denedim). siteden 2.3 minimal sürümünü tekrar indirip usb üzerinden yeniden kurulum yaptım. Erkan beyin anlatımlarıyla kde masaüstü'nü kurdum. şu an sorunsuz bir şekilde depoları güncelledim. istediğm uygulamaları da yükledim. Bana çok değerli vaktini ayırıp yardımcı olan Erkan IŞIK beye ve Kamil ATLI beye çok teşekkür ediyorum. emeğinize sağlık.

scrollup